Skip to content
This repository was archived by the owner on Nov 4, 2026. It is now read-only.

build(frontend): Apply non-breaking npm audit fixes - #73

Merged
mrduncan merged 3 commits into
mainfrom
mattduncan/ie-93-frontend-deps
Oct 28, 2026
Merged

mrduncan merged 3 commits into
mainfrom
mattduncan/ie-93-frontend-deps

Conversation

@sentry-junior

@sentry-junior sentry-junior Bot commented Oct 28, 2026 •

Copy link
Copy Markdown
Contributor

npm audit reported 95 vulnerabilities (7 critical, 39 high) in the frontend lockfile. 71 of them can be fixed with in-range updates.

This runs npm audit fix (without --force) in frontend/ and adds two npm overrides:

  • Clears all 7 critical advisories (@babel/traverse, form-data, loader-utils, proxy-addr, shell-quote, webpack, websocket-driver)
  • overrides.serialize-javascript: ^7.0.3 for GHSA-5c6j-r48x-rmvq (high). It is used at build time by css-minimizer-webpack-plugin and rollup-plugin-terser, and no react-scripts 5 dependency range allows the patched 7.x line.
  • overrides.webpack-dev-middleware: ^7.4.6 for GHSA-g84c-rxfj-3j2c (high). It is only used by the CRA dev server (webpack-dev-server 4.15.2), and there is no patched 5.x release. Version 7 is outside webpack-dev-server 4's declared range, but the dev server still starts, serves the bundle, and recompiles on change with it.
  • Both overridden packages require Node >= 18/20; the repo uses Node 24.
  • npm audit goes from 95 to 31 (0 critical, 5 high). Most of the remaining ones come through react-scripts 5, and npm only offers a breaking change to fix them.
  • react-router-dom resolves to 6.30.6, up from 6.2.x. That version logs v7 future-flag warnings in tests and the dev console.

No other package.json ranges change.

Refs IE-93

--

View Junior Session [Sentry]

sentry-junior Bot and others added 3 commits October 28, 2026 17:50
Run npm audit fix (without --force) to update in-range transitive
dependencies in the frontend lockfile. No package.json ranges change.

Refs IE-93

Co-Authored-By: Matt Duncan <[email protected]>
The audit fix moved serialize-javascript from 6.0.0 to 6.0.2, which is
still affected by GHSA-5c6j-r48x-rmvq (high) and fails dependency
review. No react-scripts 5 dependency range allows the patched 7.x
line, so pin it with an npm override.

Refs IE-93
The audit fix moved webpack-dev-middleware from 5.3.1 to 5.3.4, which is
still affected by GHSA-g84c-rxfj-3j2c (high) and fails dependency
review. There is no patched 5.x release, so override it to ^7.4.6. The
CRA dev server (webpack-dev-server 4.15.2) still starts, serves the
bundle, and recompiles on change with this override.

Refs IE-93
@mrduncan
mrduncan marked this pull request as ready for review October 28, 2026 18:52
@mrduncan
mrduncan merged commit f9189f1 into main Oct 28, 2026
15 checks passed
@mrduncan
mrduncan deleted the mattduncan/ie-93-frontend-deps branch October 28, 2026 18:58
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

2 participants