Repository navigation
chore(deps): bump the development-dependencies group across 1 directory with 20 updates - #6438
Conversation
|
The latest updates on your projects. Learn more about Vercel for GitHub.
|
Reviewer's GuideThis PR re-issues Dependabot’s development-dependency group on current staging, updating 20 packages and regenerating the pnpm lockfile. Astro remains at the separately merged 7.4.x version so the refreshed lockfile uses the rebuilt Astro patch and supports clean frozen installs; sandbox verification reports a successful install and build, with full CI as the final gate. Flow diagram for dependency refresh verificationflowchart LR
A[Update 20 development dependencies] --> B[Regenerate pnpm-lock.yaml]
B --> C[pnpm install --frozen-lockfile]
C --> D[pnpm run build]
D --> E[lint-changed type-aware]
E --> F[Full CI gate]
File-Level Changes
Possibly linked issues
Tips and commandsInteracting with Sourcery
Customizing Your ExperienceAccess your dashboard to:
Getting Help
|
px Advisor ReviewRisk: unknown No summary available No findings. |
There was a problem hiding this comment.
Hey - I've found 2 issues
Prompt for AI Agents
Please address the comments from this code review:
## Individual Comments
### Comment 1
<location path="package.json" line_range="574" />
<code_context>
"vue": "^3.5.42",
"wait-on": "^9.5.1",
- "wrangler": "^4.151.1",
+ "wrangler": "^4.153.0",
"yaml": "2.9.1"
},
</code_context>
<issue_to_address>
**Frozen installs reject Wrangler**
When CI runs `pnpm install --frozen-lockfile` or deployment scripts invoke `pnpm wrangler`, the `pnpm-workspace.yaml` override keeps Wrangler at `^4.59.1`, and the lockfile resolves it to `4.151.1` instead of matching the manifest’s `^4.153.0`; frozen installs fail, and successful dependency resolution does not deliver the declared upgrade.
Update the Wrangler workspace override and regenerate the lockfile so it matches the manifest’s `^4.153.0` range.
</issue_to_address>
### Comment 2
<location path="package.json" line_range="526" />
<code_context>
"node-gyp-build": "^4.8.4",
"nprogress": "^0.2.0",
- "oxc-parser": "^0.153.0",
+ "oxc-parser": "^0.155.0",
"oxc-resolver": "^11.24.2",
- "oxfmt": "^0.72.0",
</code_context>
<issue_to_address>
**Parser upgrade is not installed**
When pnpm resolves the root development dependency under the workspace override, the workspace override and lockfile keep `oxc-parser` at `0.151.0` despite the manifest’s `^0.155.0` range, so installing the PR does not deliver the declared upgrade.
Update or remove the `oxc-parser` workspace override and regenerate the lockfile to deliver the declared upgrade.
Also at `package.json:574`.
</issue_to_address>Sourcery assessment
Approval pending. 2 findings to address first.
Blocking findings: package.json:574, package.json:526
| "vue": "^3.5.42", | ||
| "wait-on": "^9.5.1", | ||
| "wrangler": "^4.151.1", | ||
| "wrangler": "^4.153.0", |
There was a problem hiding this comment.
🔴 Critical · Frozen installs reject Wrangler
When CI runs pnpm install --frozen-lockfile or deployment scripts invoke pnpm wrangler, the pnpm-workspace.yaml override keeps Wrangler at ^4.59.1, and the lockfile resolves it to 4.151.1 instead of matching the manifest’s ^4.153.0; frozen installs fail, and successful dependency resolution does not deliver the declared upgrade.
Update the Wrangler workspace override and regenerate the lockfile so it matches the manifest’s ^4.153.0 range.
Prompt for AI agents
In `package.json` at line 574:
**Frozen installs reject Wrangler**
When CI runs `pnpm install --frozen-lockfile` or deployment scripts invoke `pnpm wrangler`, the `pnpm-workspace.yaml` override keeps Wrangler at `^4.59.1`, and the lockfile resolves it to `4.151.1` instead of matching the manifest’s `^4.153.0`; frozen installs fail, and successful dependency resolution does not deliver the declared upgrade.
Update the Wrangler workspace override and regenerate the lockfile so it matches the manifest’s `^4.153.0` range.| "node-gyp-build": "^4.8.4", | ||
| "nprogress": "^0.2.0", | ||
| "oxc-parser": "^0.153.0", | ||
| "oxc-parser": "^0.155.0", |
There was a problem hiding this comment.
🟡 Medium · Parser upgrade is not installed
When pnpm resolves the root development dependency under the workspace override, the workspace override and lockfile keep oxc-parser at 0.151.0 despite the manifest’s ^0.155.0 range, so installing the PR does not deliver the declared upgrade.
Update or remove the oxc-parser workspace override and regenerate the lockfile to deliver the declared upgrade.
Also at package.json:574.
Prompt for AI agents
In `package.json` at line 526:
**Parser upgrade is not installed**
When pnpm resolves the root development dependency under the workspace override, the workspace override and lockfile keep `oxc-parser` at `0.151.0` despite the manifest’s `^0.155.0` range, so installing the PR does not deliver the declared upgrade.
Update or remove the `oxc-parser` workspace override and regenerate the lockfile to deliver the declared upgrade.
Also at `package.json:574`.
Lighthouse CI ResultsRoutes audited: Thresholds: Performance ≥90 | Accessibility ≥90 | Best Practices ≥85 Reports
|
Summary
Re-issues dependabot's development-dependencies group (originally #6419) on top of current staging. Same 20 bumps, regenerated lockfile.
Dropped from the original group:
astro(staging is already on^7.4.2via #6435).Why a re-issue instead of #6419
#6419 cannot install on current staging:
patches/astro.patch(lockfilepatchedDependencieshash2571b359), while astro 7.4.x needs the rebuilt patch (74950e75) merged in chore(deps): bump astro to 7.4.x and rebuild its patch #6435 — sopnpm installdies atERR_PNPM_PATCH_FAILED.@dependabot rebaselanded the branch onc648884e5, one commit behind staging (b624bd279, the astro-patch merge), and the PR stayedDIRTY;@dependabot recreateproduced no new commit.Bumps
@astrojs/markdoc2.1.1 ·@astrojs/react7.1.1 ·@axe-core/playwright4.14.0 ·@composio/vercel0.13.0 ·@graphql-codegen/typescript-operations6.2.0 ·agents0.30.1 ·dependency-cruiser18.7.0 ·eslint10.13.0 ·eslint-plugin-n18.5.0 ·headroom-ai0.42.0 ·knip6.43.0 ·markdownlint0.42.0 ·markdownlint-cli0.50.0 ·mcp-remote0.15.2 ·oxc-parser0.155.0 ·oxfmt0.74.0 ·oxlint1.89.0 ·rollup4.65.1 ·satori0.63.2 ·wrangler4.153.0Verification (in E2B sandbox, node 24)
pnpm install --frozen-lockfile— clean.pnpm run build—Complete!(astro 7.4.4 + vite 8.3.5).node scripts/ci/lint-changed.mjs --type-aware— 12 warnings, 0 errors.Summary by Sourcery
Refresh the development dependencies and lockfile to keep the project tooling and integrations current.
Enhancements:
Build: