While validating Lab 9, Instructions -> 20-enhance-postgresql-development.md, the deployment fails due to a soft‑deleted Cognitive Services/Text Analytics resource in the subscription. Azure blocks creating a new one and returns the FlagMustBeSetForRestore error. Just reporting that I’m hitting this issue during validation.
Lab 09
Ex: Before you start, Step 7

While validating Lab 9, Instructions -> 20-enhance-postgresql-development.md, the deployment fails due to a soft‑deleted Cognitive Services/Text Analytics resource in the subscription. Azure blocks creating a new one and returns the FlagMustBeSetForRestore error. Just reporting that I’m hitting this issue during validation.
Lab 09
Ex: Before you start, Step 7