Repository navigation
chore(deps-dev): bump eslint-config-next from 16.3.6 to 16.3.8 - #25
dependabot[bot] wants to merge 1 commit into
Conversation
Bumps [eslint-config-next](https://github.com/vercel/next.js/tree/HEAD/packages/eslint-config-next) from 16.3.6 to 16.3.8. - [Release notes](https://github.com/vercel/next.js/releases) - [Commits](https://github.com/vercel/next.js/commits/v16.3.8/packages/eslint-config-next) --- updated-dependencies: - dependency-name: eslint-config-next dependency-version: 16.3.8 dependency-type: direct:development update-type: version-update:semver-patch ... Signed-off-by: dependabot[bot] <[email protected]>
There was a problem hiding this comment.
This PR bumps eslint-config-next from 16.3.6 to 16.3.8 in devDependencies, along with the corresponding lockfile updates for its transitive dependencies (typescript-eslint 8.71.0→8.71.1, browserslist, axe-core, caniuse-lite, and several other minor packages). Notably, the next package in dependencies is not updated and remains at 16.3.6, creating a version mismatch with eslint-config-next — these two packages are designed to be kept in lockstep by the Next.js team.
Reviewer callouts (1)
Non-blocking observations. Nothing here needs to change before merge.
.github:1— "The ubuntu-latest label will migrate to Ubuntu 26 beginning October 19, 2026. For more information, see actions/runner-images#14748"
| "@vitejs/plugin-react": "^6.0.2", | ||
| "eslint": "^9", | ||
| "eslint-config-next": "16.3.6", | ||
| "eslint-config-next": "16.3.8", |
There was a problem hiding this comment.
[WARNING] agentic/design
eslint-config-next (16.3.8) is now two patch versions ahead of next (16.3.6 in dependencies). These two packages are released in lockstep by the Next.js team and are designed to match exactly — eslint-config-next re-exports @next/eslint-plugin-next at the same version, which contains lint rules that may reference APIs and patterns specific to the corresponding Next.js release. Running a mismatched pair can cause false positives (new rules flagging valid 16.3.6 patterns) or false negatives (lint rules not checking for issues that exist in 16.3.6). The standard practice is to keep both at the same version.
Suggested fix:
Either bump `next` to `16.3.8` in `dependencies` to match, or revert `eslint-config-next` back to `16.3.6` until `next` itself is ready to be upgraded:
```json
"dependencies": {
...
"next": "16.3.8",
...
},
"devDependencies": {
...
"eslint-config-next": "16.3.8",
...
}
<!-- justalab-agents:hash:4fe899dc1c4d -->
Bumps eslint-config-next from 16.3.6 to 16.3.8.
Release notes
Sourced from eslint-config-next's releases.
Commits
b0fad0dv16.3.84c20699v16.3.7Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting
@dependabot rebase.Dependabot commands and options
You can trigger Dependabot actions by commenting on this PR:
@dependabot rebasewill rebase this PR@dependabot recreatewill recreate this PR, overwriting any edits that have been made to it@dependabot show <dependency name> ignore conditionswill show all of the ignore conditions of the specified dependency@dependabot ignore this major versionwill close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)@dependabot ignore this minor versionwill close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)@dependabot ignore this dependencywill close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)