From 1383831e2cebcdef45e74f27c6aebfd4b272f4fa Mon Sep 17 00:00:00 2001 From: stack72 Date: Mon, 19 Jan 2026 16:24:28 +0000 Subject: [PATCH] chore(ci): Upgrade CI node version MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit Fixes build failure in upgrade-web.yml workflow caused by Node.js version incompatibility. The workflow was failing with crypto.hash is not a function error after recent dependency upgrades. The root cause: `@vitejs/plugin-vue` was upgraded from `v5.1.4` to `v6.0.3` (in commit `0f68f1237c`), and `v6.x `uses `crypto.hash()` which requires `Node.js 19+`. #### Why Node 20: - Supports crypto.hash() (added in Node 19) - Aligns with project's package.json engines requirement: `"node": "^20.0.0 || ^22.0.0”` - Compatible with `@vitejs/plugin-vue@6.0.3` --- .github/workflows/e2e-validation.yml | 2 +- .github/workflows/upgrade-web.yml | 2 +- .github/workflows/webworker-validation.yml | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-) diff --git a/.github/workflows/e2e-validation.yml b/.github/workflows/e2e-validation.yml index 64b644eca1..b624ea4a36 100644 --- a/.github/workflows/e2e-validation.yml +++ b/.github/workflows/e2e-validation.yml @@ -229,7 +229,7 @@ jobs: - name: Setup Node.js uses: actions/setup-node@v4 with: - node-version: '18.18.2' + node-version: '20' - name: Setup pnpm uses: pnpm/action-setup@v4 diff --git a/.github/workflows/upgrade-web.yml b/.github/workflows/upgrade-web.yml index 85aa04f540..c56cfcbefc 100644 --- a/.github/workflows/upgrade-web.yml +++ b/.github/workflows/upgrade-web.yml @@ -43,7 +43,7 @@ jobs: - uses: actions/setup-node@v5 with: - node-version: '18.18.2' + node-version: '20' cache: 'pnpm' - name: Install dependencies diff --git a/.github/workflows/webworker-validation.yml b/.github/workflows/webworker-validation.yml index 9906ef3193..a46db8facd 100644 --- a/.github/workflows/webworker-validation.yml +++ b/.github/workflows/webworker-validation.yml @@ -18,7 +18,7 @@ jobs: - name: Setup Node.js uses: actions/setup-node@v4 with: - node-version: '18.18.2' + node-version: '20' - name: Setup pnpm uses: pnpm/action-setup@v4