Skip to content

build(deps): update scipy requirement from >=1.15.3 to >=1.17.1 #68

build(deps): update scipy requirement from >=1.15.3 to >=1.17.1

build(deps): update scipy requirement from >=1.15.3 to >=1.17.1 #68

Workflow file for this run

name: CI
on:
push:
branches: [master]
pull_request:
workflow_call: # the release workflow runs the same checks first
jobs:
lint:
runs-on: ubuntu-latest
steps:
- uses: actions/checkout@v7
- uses: actions/setup-python@v7
with:
python-version: "3.12"
- run: pip install ruff
- run: ruff check .
- run: ruff format --check src tests
test:
runs-on: ubuntu-latest
strategy:
fail-fast: false
matrix:
python-version: ["3.11", "3.12", "3.13"]
steps:
- uses: actions/checkout@v7
- uses: actions/setup-python@v7
with:
python-version: ${{ matrix.python-version }}
- name: System libraries for Gmsh and the CalculiX solver
run: sudo apt-get update && sudo apt-get install -y libglu1-mesa libxrender1 libxcursor1 libxft2 libxinerama1 calculix-ccx
- run: command -v ccx # the CalculiX tests skip silently without it
- run: pip install -e ".[dev]"
- run: pytest -q